I can’t access the V3 app on my phone

Hi, have downloaded the app to my phone but it won’t work. It’s a new phone

2 Comments.

  • Have you tried turning your phone off and on again? Worked for me. Good luck! 🙂

  • VICTVS Support
    7 October 2020 9:12 am

    Hi there. Thanks for posting. I can see from your screenshot that your device’s operating system is Android version 7.1.1. VICTVS V3 requires devices to be running at least version 8 of Android.

    Please update your device and then try to access the VICTVS V3 app again – it should work fine.

    Thanks

    VICTVS Support

    VICTVS V3 minimum specification:

    • iOS – iOS 13.4 and above. Devices – iPhone 7,7 plus, 8, 8 plus, X, XS, XS Max, XR, 11, 11 pro, 11 Max Pro, SE (2nd gen), iPad Air 2 (and above), iPad Mini 4, All iPad Pro models

    • Android – 8.0 and above.

Menu